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Tutorials
The lessons in this tutorial give you the chance to learn Toon Boom Studio using realistic 
examples. 

These self-contained lesson can be completed in any order, this allows you to learn about 
the features that interest you most.

The material for each lesson is included in the Tutorials folder of the Toon Boom Studio 
application folder on your computer.

This chapter includes the following lessons:

• Lesson 1: Drawing on page 4

• Lesson 2: Painting on page 13

• Lesson 3: Lip Syncing on page 23

• Lesson 4: Building a Multiplane Scene on page 31

• Lesson 5: Creating Cross-Dissolves with Colour Transform Elements on page 46

• Lesson 6: Creating Clipping Mask Effects on page 55

• Lesson 7: Retouching Drawings in Sceneplanning on page 59
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Lesson 1: Drawing
In this lesson, you will work with Toon Boom Studio drawing tools to create frame-by-
frame animation. 

There are two animation projects for this lesson:

• Drawing_Rough
• Drawing_Final

You’ll use the Drawing_Rough animation project to complete a walk cycle. You’ll use the 
onion skin, rotary light table, and the Toon Boom Studio centreline drawing tools and 
pressure-sensitive Brush tool to draw the old man.

               

To start the Drawing lesson:

1. Download the Quick Start Tutorial files from the Toon Boom Animation website. You 
can click the Quick Start Tutorial link on the Welcome Screen to open the 
appropriate Web page.

2. Open the Drawing_Rough animation project in the Lesson1_Drawing folder.

3. Save the animation in a location of your choice using File > Save As. Saving this 
animation project to a new location will ensure that you always have the original to 
return to and use should you want to.

You will show this 
old man so he 
fits between 
the previous 
and next frames.

current frame

previous frame next frame
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Step 1: Drawing the Old Man’s Head
In this step, you will draw the head of the old man using the Ellipse tool. Because this 
drawing must fit with the other drawings in the element to create a complete cycle, you 
will use the onion skin to show previous and next drawings of an element as a reference 
while you draw.

To draw the old man’s head:

1. In the Exposure Sheet window, click the first cell in the rough-oldman element and 
press the down arrow key on your keyboard. As you cycle through all of the drawings 
in the rough-oldman element, you’ll notice that there is no drawing in the rough-
oldman-2 cell. That’s because you are going to draw it!

2. Click the Drawing View window and set it up so that you have a clear view of the old 
man.

To turn on and off the grid, press [G], the default keyboard shortcut.
To zoom in, press [X], and to zoom out press [Z].
To pan the Drawing View window, press and hold [Spacebar] and use the 
Grabber tool to change the part of the window you are seeing.

3. Select the rough-oldman-2 cell. 
5
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4. In the toolbar, click the Onion Skin button to turn on the onion skin feature. When 
the onion skin is active, the button looks like it is pressed in.

 

5. Click the Show Previous  button and select Previous Drawing and click the Show 

Next  button and select Next Drawing. 

In the Drawing View window, the previous and next drawings in the onion skin 
appear in a different colour to distinguish them from the drawing you are working 
on.

6. Select the Ellipse  tool from the Drawing Tools toolbar. 

7. If the Properties window is not open, select Window > Properties. The Properties 
window appears. 
6



 Lesson 1: Drawing
8. In the Pen tab, type 20 for the Maximum Size value. 

When you draw with the centreline tools (including the Pencil, Rectangle, Ellipse, 
Polyline and Line) Toon Boom Studio uses the Maximum Size value for the width of 
the line.

9. In the Drawing View window, draw an ellipse roughly the shape of the old man’s 
head. Don’t worry about the actual shape not being the same as the one in the 
animation. You will reshape it using the Contour Editor tool.

10. Save your animation using the File > Save command.
7
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Step 2: Reshaping the Old Man’s Head
In this step, you will use the Contour Editor tool to move the points that make up the 
ellipse you drew in step 1 and reshape the old man’s head.

To reshape the old man’s head:

1. From the Drawing Tools toolbar, select the Contour Editor.

2. Click the ellipse you drew in step 1. You’ll notice that a line appears down the center 
of the shape (a centreline) and that there are points on this line.

3. Use the Contour Editor to reshape the ellipse by moving the points and dragging 
the Bezier handles. (To get the Bezier handles to appear, click a point on the 
centreline.) 

The final shape should be approximately the same shape as the old man’s head 
shown in the previous drawing.

4. Save your work using the save command. Select File > Save.

After you reshape the ellipse, 
it should look like this
8
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Step 3: Using the Brush Tool to Draw the Old Man

In this step, you use the Brush  tool to draw the head and then the rest of the old man.

Unlike the Ellipse tool and other centreline tools (Rectangle, Polyline, Line and Pencil), the 
Brush tool creates variable-width strokes that respond to the pressure you apply with a 
digital pen and graphic tablet. 

When you draw with the Brush tool, Toon Boom Studio creates shapes that are formed by 
points that surround a zone, which is filled with colour. We call the shapes created by the 
Brush tool “contour shapes”. 

Drawing with the Brush tool allows you to create distinctive lines that are more natural 
than the mechanical looking centreline shapes. However, brush strokes require more 
memory to store because they use more points to create. If you are concerned about the 
file size of your animation, consider this carefully when choosing your drawing tools.

To draw the old man with the Brush tool:

1. Select the Brush tool from the Drawing Tools toolbar. 

2. In the Pen tab, type 5 for the Minimum Size value. When you draw with a graphic 
tablet and pen, Toon Boom Studio uses the Minimum Size and Maximum Size 
values to determine the width of the variable-width line.

3. In the Drawing View window, use the Brush tool to draw a circle approximately the 
same shape as the old man’s ear as shown in the previous drawing in the onion skin.

4. Using the Contour Editor tool, [Shift]-click the old man’s ear drawing and the old 
man’s head. Notice the number of points in old man’s ear, drawn using the Brush 
tool, and the old man’s head, drawn using the Ellipse tool.
9
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When you have finished comparing the drawings deselect them by clicking anywhere in 
the Drawing View window. 

5. Using the Contour Editor tool and the curve handles, reshape the old man’s ear you 
drew so that it is approximately the same shape as the old man’s ear shown in the 
previous drawing in the onion skin.

6. Draw the rest of the old man. The completed drawing must fit in the walk cycle, so 
you must draw the old man’s legs so that his left leg is goes down and his right leg is 
moving up. 

A Brush stroke is 
surrounded by a 
collection of points. 
The outline of the 

brush stroke or painted 
fill is called a contour.

A Line drawn using the 
Ellipse tool is defined by 

a series of centreline 
points.

After you reshape 
the ear drawing it 

should look like this
10



 Lesson 1: Drawing
When you finish drawing, your old man should look something like this.

You can look at the final drawing in the Drawing_Final animation project to see how we 
did it.

7. To help you with your drawing, you can use the Rotary Light Table so that you can 
get a better angle on the part of the drawing you are working on.

To display the Rotary Light Table, hold down [Ctrl]+[Alt] when using Windows or 
[Ctrl]+[Command] when using MacOS, then use your mouse to freely rotate your 
drawing space.

To return your drawing space to the original angle, select View > Reset Rotation 
or press [Shift] + [C].
11
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Step 4: Previewing the Old Man Cycle
In this step, you use the Interactive Playback buttons to preview your drawing of the old 
man and see how it fits into the run cycle.

To preview the Old Man cycle using Interactive Playback:

1. In the Exposure Sheet window, press [Shift] and select drawings 1 through 8.

2. Press Play .

All of the selected content plays in sequential order in the View window.

3. If you want the playback to repeat, select the Loop  button before you click the 
Play  button.

4. Make corrections to your old man drawing so that the transition between the 
drawings in the cycle is logical and smooth.

5. Save your animation project and you are done!

Congratulations on completing the first lesson in this tutorial.
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 Lesson 2: Painting
Lesson 2: Painting
In this lesson, you will paint the old man, and give him some colour. 

There are two animation projects for this lesson:

• Painting_Rough
• Painting_Final

In the Painting_Rough animation project, you’ll build a colour palette for the old man and 
create a gradient colour swatch. Then you’ll paint the old man using Toon Boom Studio 
power-paint features that will speed the painting process.

To start the Painting the Old Man lesson:

1. Download the Quick Start Tutorial files from the Toon Boom Animation website. You 
can click the Quick Start Tutorial link on the Welcome Screen to open the 
appropriate Web page.

2. Open the Painting_Rough animation project in the Lesson2_Painting folder.

3. Save the animation in a location of your choice using File > Save As. 

4. Click the Play  button and watch the old man walk! 

You’re going to give the old man some colour, and the candle, a little bit of light!
13
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Step 1: Adding a Colour Swatch
In this step, you’ll add a colour swatch to the old man’s colour palette.

To add a colour swatch:

1. If the Properties window is not open, select Window > Properties. The Properties 
window appears. 

2. Click the Colour Palette tab. The Colour Palette tab appears with the default set of 
colours. 

3. From the Name drop-list, select old man. This is the old man colour palette, which 
you can use to organize all of the colour swatches for this character.

4. You can click the Show/Hide Colour Name button on the right side of the dialog 
box, just above the swatch scroll bar. This changes the display to a list of swatches 
and their names.

5. Select the lines flame colour swatch and click the Add a Colour  button. A copy of 
the lines flame swatch appears in the palette style and it is called New 1 by default. 
You will edit the properties of this colour swatch in the next step.

This Colour Pallette provides 
all of the colour swatches you 
need to paint.

The Show Colour 
Names button, displays 

the names of the swatches.
14
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Step 2: Creating a Gradient “Flame” Swatch
In this step, you will create a gradient for the candle flame. You’ll use the swatch you 
created in the previous step as the basis for the gradient.

To create a gradient: 

1. Double-click the colour swatch you added in the last step. You’ll use this swatch as a 
basis for the gradient because the orange colour in the swatch is similar to one of the 
gradient colours.

The colour picker opens.

 

2. Select the Gradient option.

Gradient

The look of your colour picker is dependent on 
your operating system.
15
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3. In the Gradient panel, select Radial. The colours in a radial gradient blend in a 
circular pattern.

4. Click the first marker below the Gradient bar. A square appears in the marker to 
indicate that it is editable.

5. Change the colour of the first marker to yellow by dragging your mouse in the colour 
swatch. We used these R, G, B values: 248, 251, 17. You can use the Colour slider, or 
enter these values manually, if you want.

6. Click below the Gradient bar to add a gradient marker. The colour of the marker is 
the same as the marker you had selected. Gradient markers represent the start or 
end of a transition between different colours.

7. Do one of the following: 
In the Opacity field, type 60 (MacOS).
In the Alpha field, type 150 (Windows). 

8. Change the value of the last colour to red. 
You can use these specific values: 236, 0, 0.

9. Close the colour picker and that’s it! You have created a gradient swatch!

First colour Last colour

Transition 
colour
16
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Step 3: Painting the Flame on the Candle
Now that you have created a gradient for the flame, you are ready to paint.

To paint the flame on the candle:

1. In the Exposure Sheet window, select the first drawing in the ColourMe element. 
the old man appears in the Drawing View window.

2. Set up the Drawing View window so that you have a clear view of the candle.
To turn off the grid, press [G], the default keyboard shortcut.
To zoom in, press [X], and to zoom out press [Z].
To pan the Drawing View window, press and hold [Spacebar] and use the 
Grabber tool to change the part of the window you are seeing.

3. Select the Paint  tool from the Drawing Tools toolbar.

 

4. From the Colour Palette tab, select the gradient swatch you created for the flame.
17
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5. Click the areas of the flame with the Paint  tool.

 

6. Scroll through the old man drawings and paint all of the flame areas. 

Press [S] to advance to the next frame and press [A] to return to the previous frame.

You’ll notice that after you paint drawing 8, you will come to drawings that have 
already been painted. That’s because we repeated drawings 1 through 8 in the 
element to create a cycle. Because each cell in the Exposure Sheet window refers to 
a drawing in the animation project, when you update a drawing that is repeated in 
other frames, Toon Boom Studio updates all frames that reference that drawing.
18
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Step 4: Editing the Direction of the Flame
Now that the candle flame has been painted it requires some minor editing to make it look 
more natural.

In this step, you will use the Edit Texture tool to change the position and length of the 
flame gradient.

To edit the flame in the painted zone:

1. Select the Edit Texture tool from the Drawing Tools toolbar. 

2. With the Edit Texture tool, click the flame gradient in one of the old man drawings. 
The gradient editor appears.

3. Grab the handles to rotate the gradient or change its length. You want to create an 
effect that looks more natural, so experiment with the Edit Texture tool.

                      

Use the handles to 
reshape the gradient.

Drag the centre of the 
Gradient Editor If you 
want to change the 

look of the Flame’s 
gradient colour.
19
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Step 5: Painting the Old Man drawing
In this step, you are going to use Toon Boom Studio’s powerful automatic painting 
features.

You click a zone in one drawing and Toon Boom Studio scrolls through the rest of the 
drawings in the elements to check if there is a closed zone beneath where you clicked. If 
there is a closed zone, Toon Boom Studio automatically paints the zone with the same 
colour.

Another feature you need to be aware of is auto gap closing, before you can fill a zone 
with colour, it has to be completely closed. Sometimes, when you draw with the Brush 
tool, you may not always close zones completely. When you are painting, you can set a 
threshold for line gaps so that Toon Boom Studio will paint zones regardless of the size of 
the gap that keeps them open.

To paint the old man:

1. From the Tools > Auto Gap menu, select Close Large Gap. 

2. In the Exposure Sheet window, select the colourMe-1 drawing.

3. Press [X] to zoom in on the drawing so that you can see the zones clearly.

4. Select the Paint tool from the Drawing Tools toolbar.

5. In the Colour Palette tab, click the skin colour swatch in the old man colour palette. 

6. Press [Shift]+[Option] in MacOS, or [Shift]+[Alt] in Windows, and click the old man’s 
face. Your pointer changes to indicate that the Paint All tool is active.

After it is done, scroll through the drawings to check that the face on all of the drawings 
are painted with the same skin colour swatch. You may have to manually correct some 
20



 Lesson 2: Painting
drawings because of where you clicked on the drawing (it might overlap other zones, for 
example). 

               

7. Continue to use the Paint All tool until all the static areas of your drawing are 
coloured.

8. Next, you will paint the smaller zones one at a time. Using the names of the colour 
swatches to identify which zones they belong to on the old man, click those zones 
with the Paint tool. Each zone will be filled with colour.

                

Click here with the Paint All tool and 
it will paint the same area in all of the 
drawings in the element.
21
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Step 6: Export
Now you are ready to export your creation and share it with your friends and family.

To export your animation:

1. Select File > Export Movie. The Export dialog box opens.

2. From the Export Format menu, select Flash Movie.

3. Select Default from the Settings menu. 

4. Type the name of the movie in the File Name field and click the Browse button on 
the right if you want to select an alternate location for the final file. 

5. Select Full Movie from the Export Type panel.

6. Select the Launch Player After Export option.

7. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export. If you want to cancel the export, click Cancel. 

When the export process is complete the Adobe Flash movie automatically opens in 
a Flash player.
22
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Lesson 3: Lip Syncing
Lip syncing is typically considered to be the most tedious task in the animation process. 
Traditionally, before you can even begin drawing the lip positions, you have to analyze the 
voice track to determine what lip position best matches the sound at each frame. 

With Toon Boom Studio, the easy-to-use lip sync tool analyzes the sounds in a voice track 
and generates a lip chart based on the eight animation phonemes. In addition to that, 
Toon Boom Studio has a tool that will automatically map drawings in an element based on 
the sounds they match. These two tools together will save you time so that you can focus 
on more interesting and creative tasks.

There are two animation projects for this lesson:

• Lip_Sync_Rough
• Lip_Sync_Final

To start the Lip Sync lesson:

1. Download the Quick Start Tutorial files from the Toon Boom Animation website. You 
can click the Quick Start Tutorial link on the Welcome Screen to open the 
appropriate Web page.

2. Open the Lip_Sync_Rough animation project in the Lesson3_LipSync folder.

3. Save the animation in a location of your choice using File > Save As. 

Just look at Deb Ant! So nervous? 

Looks like she’s got something to say.
23
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Step 1: Importing Deb Ant’s Voice Track
In this step, you will import a speech made by Deb while she’s at the Survivor Ant tribal 
council meeting. 

In Toon Boom Studio, you must import sounds into Sound elements so you must add a 
sound element first.

To import Deb Ant’s voice track:

1. Click the Add Sound Element  button at the top of the Exposure Sheet window. 
An empty sound element appears in the exposure sheet. 

2. Select Element > Rename Element and use the Rename Sound Element dialog box 
to name the element debSpeaks.

3. Right-click (Windows) or [Control]-click (MacOS) the first cell in the element and 
select Import Sound > From File from the pop-up menu. The Open dialog box 
opens.

4. Browse the Lesson3_LipSync folder and select please_dont.MP3 and click Open. 
The sound file now appears in the cell you selected. 

5. Turn-up your headphones or speakers, [Control]-click (in MacOS) or right-click (in 
Windows) the first cell in the debSpeaks element and select Play from the pop-up 
menu. Listen as Deb Ant begs not to be kicked out of the tribe.

Step 2: Generating a Lip Chart for Deb Ant
In this step, you will use Toon Boom Studio to generate a lip chart that matches Deb Ant’s 
speech to a set of animation phonemes. You can use the lip chart as a reference as you 
draw the lip sync images for your characters. 

To generate a lip chart for a Deb Ant’s voice track:

1. Select the debSpeaks element and select Element > Edit Sound. The Sound 
Element Editor appears.

2. In the Sound Element panel, click the wave form of the sound track and click the 
Streamed checkbox to set up this sound for streaming. 
24
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Voice tracks are best set as streamed sounds because they begin playing before the 
entire sound is loaded and will better maintain synchronization with images in Adobe 
Flash movies.

 

3. Select the waveform in the Sound Element panel and click the Lip-Sync button. A 
progress bar appears as Toon Boom Studio analyzes the selected sound clips and 
assigns a lip sync letter to each frame.

The lip sync images on the right side of the window become active. Drag the frame 
slider in the Sound Element panel to see the lip position for each frame of sound.

4. Select the Enable Scrubbing option at the bottom of the Sound Element Editor. 
Scrubbing allows you to slowly play the sound forward and backward.

Here’s the Streamed 
checkbox.
25
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5. Drag the frame slider at the top of the Current Sound panel to “scrub” the sound 
track and hear for yourself the sound that Deb is making at each frame. 

6. Click OK to close the Sound Element Editor and then save your animation project.

Step 3: Drawing Deb Ant’s Missing Lips
In the sample Lip Sync lesson, we drew six out of seven of the lip positions for Deb Ant. It 
is up to you to draw Deb’s lip for the “D” position using the lip sync preview images.

To draw Deb Ant’s missing lips:

1. In the Exposure Sheet window, press [Ctrl] (Windows) or [Command] (MacOS) and 
drag the debSpeaks element so that it is next to the mouth column. This will make it 
easier for you to see the lip chart while you are working on Deb’s lips.

2. Right-click (Windows) or [Control]-click (MacOS) a cell in the debSpeaks element and 
select Show Lip-sync from the pop-up menu. Toon Boom Studio displays the 
phoneme assigned to each frame in the sound.

3. Click the Toggle Thumbnails button to show the lip chart.

This is the Toggle Thumbnails 
button. Click it and you will see 
preview images for the lip chart you 
computed.
26
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4. Scroll down the Exposure Sheet window. At the frame in the debSpeaks element that 
is labelled D, you must double-click the equivalent cell in the mouth element and 
rename the drawing D.

5. Now, with the lip sync preview image as a reference, draw Deb Ant’s lips in the D 
position. After you have finished drawing her lips, paint them using the swatches in 
the Deb Ant colour palette on the Colour Palette tab.

This is how Deb Ant’s lips look in the D position we drew.

Here are some tips that will help you out:

Use the Stroke tool to create a closed zone without visible line art.
Use the Close Gap tool to close the zone in the neck so that you can paint it.
You can copy and paste drawings from previous cells (try the F cell) and modify 
them to suit the lip position.
The lips must fit on Deb Ant’s head. 

You can use the onion skin to display the previous and next drawings and 
use those drawings as a reference.
You can use the Auto Light Table to display other drawings in the frame, 
including Deb. You will need to hide other elements (using the Element List) 
to display only selected elements.

Cell labels link the contents of the 
cell to a file in your animation 
project.
27
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You can add a drawing (like the F drawing) to the Static Light Table so that 
you can use it as a reference.

Set up the Drawing View window so that you have a clear view of Deb Ant.
To turn off the grid, press [G], the default keyboard shortcut.
To zoom in, press [X], and to zoom out press [Z].
To pan the Drawing View window, press and hold [Spacebar] and use the 
Grabber tool to change the part of the window you are seeing.

Step 4: Auto-Mapping Deb Ant’s Lips to Her Voice 
Track
In the Lip Sync Mapping dialog box, you identify each phoneme drawing for a character 
and then Toon Boom Studio automatically labels all of the cells in the character’s element 
with the appropriate label for each phoneme drawing.

To make this feature really work for you, it is best if you name your drawings with the seven 
phonemes and the closed mouth position: A, B, C, D, E, F, G, and X.

In the mouth element, we have already named all the elements with the letters of the 
seven plus one phonemes. All you have to do is map the drawings to the phonemes in this 
element, and Toon Boom Studio will do the rest of the work for you. For Deb’s lips, you 
are going to use the same drawing for the A position and the X position.

To auto-map Deb Ant’s lips to the voice track:

1. Select the first drawing in the mouth element and press the arrow keys to scroll down 
the drawings in this element. You’ll see that the mouth positions do not reflect the lip 
chart that you generated.
28
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2.  the title of the debSpeaks element and select Modify Lip-Sync Mapping from the 
pop-up menu. The Lip-Sync Mapping dialog box opens. 

3. From the Destination element pull-down list, select mouth. This is the element that 
you are going to apply the auto-map to.

4. In the X field, type A. For Deb’s lips, you are going to use the same drawing for the A 
position and the X position.

5. Click OK. The dialog box closes. 

6. If you scroll through the mouth element now, you’ll see that all of the lip drawings 
have been mapped to the phonemes in Deb’s voice track.
29
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Step 5: Export
It’s time to export your lip sync scene.

To export your animation:

1. Select File > Export Movie. The Export dialog box opens.

2. From the Export Format menu, select Flash Movie.

3. Select Default from the Settings menu. 

4. Type the name of the movie in the File Name field and click the Browse button if you 
want to select an alternate location for the final file. 

5. Select Full Movie from the Export type panel.

6. Select the Launch Player After Export option.

7. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export. If you want to cancel the export, click Cancel. 

Your Adobe Flash movie opens automatically in a Flash player when the export has 
finished.
30
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Lesson 4: Building a Multiplane Scene
One of the great attributes of Toon Boom Studio is the 3D scene space and the camera, 
which allows you to design multiplane moves and cinematic camera effects. 

In this lesson, you’ll create a multiplane camera move that follows the action, as well as 
make the old man cross the room. In the process of all this, you will also get to work a bit 
with templates and smooth moves using specific features on your motion paths.

 

There are two animation projects for this lesson:

• Sceneplanning_Rough

• Sceneplanning_Final

To start the Building a Multiplane Scene lesson:

1. Download the Quick Start Tutorial files from the Toon Boom Animation website. You 
can click the Quick Start Tutorial link on the Welcome Screen to open the 
appropriate Web page.

2. Open the Sceneplanning_Rough animation project in the Lesson4_Sceneplanning 
folder.

3. Save the animation in a location of your choice using File > Save As. 

4. Play back the rough animation by selecting the Play command from the Play menu. 
Not really much to see, eh? Nothing moves, nothing happens. Go to Step 1 to create 
some more interesting visual effects in this scene.
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Step 1: Attaching the Camera to the Peg
The first step in this lesson is to create a camera move using a peg.

The idea of the Toon Boom Studio digital peg system was inspired by traditional 2D cel 
animation. In traditional animation, cycles of animation are typically drawn in-place. To 
make characters move through the cycle, animators would use peg bars, which would 
ensure that the drawings changed position gradually and precisely.

In Toon Boom Studio, you use pegs to create different types of changes over time. In 
addition to motion, you can also create scaling and rotation effects using pegs. 

Toon Boom Studio also features “cameras”, which are like traditional cameras that “film” 
the action in a scene. In Toon Boom Studio, you can combine these two features - cameras 
and pegs - to create camera moves like trucks and pans.

In Toon Boom Studio, you use one camera and can add up to two pegs in your scene. 
Using Toon Boom Studio, you can add unlimited cameras and pegs to create even more 
sophisticated scenes. 

For this step, we’ve already created the motion path that the camera will follow. All you 
have to do is attach the camera to the peg.

In the View windows, you can see the elements in your scene from the front, side and top:

• Here’s a motion path we created with a peg

• Here’s the camera
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To attach the camera to the peg:

1. In the Timeline window, drag and drop the Camera element on top of the Peg-
camera element.

The Camera element appears indented below the Peg-camera element to indicate 
that it is attached.

2. Select Play > Play to play back the scene. Watch the camera as it follows the motion 
path of the peg.

Step 2: Adding the Old Man Template to the 
Scene
Templates are re-usable pieces of animation that you can share within a scene, with 
different scenes in the same animation project or with many animation projects. Templates  
help you reduce your workload through re-use, keep the file size of your animations small, 
and facilitate working in a group on the same project. 

For example, you can create a template of a walk cycle and send the template file (with 
the extension TBT) to your friend so that she can incorporate it into her animation.

You can create templates out of anything you draw or import into Toon Boom Studio - 
vector drawings, bitmaps, entire elements, groups of elements, sound or SWF files. With 
a template, you have a package of all the objects, making it easy to transport and manage. 
If you create templates from multiple elements, Toon Boom Studio even maintains timing 
(exposure) and layout information with the templates.
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We created a template of the walk cycle of the painted old man. All you have to do is to 
drag it into the Timeline window and you will have added it to your scene.

To add the old man template to the scene:

1. Select Window > Library to open the Library window. The Library window is your 
center for Toon Boom Studio content management.

2. Open the Local folder, double-click the old man walk cycle.tbt file and click the
Play  button in the Library window’s preview panel. Watch the old man walk in 
place.

3. Drag the old man template file, from the Library window to the Timeline window. 
Drop it just under the plant_OL element in the list. 

  

4. Save your animation project and move on to the next step, where you will make old 
man walk across the room.

From the Library window, you can use:

• The Animation folder to access all 
of the vector drawings in your 
animation.

• The Local folder to manage all of 
the templates in your current 
animation project. Local templates 
are available to the current 
animation project only.

• The Global folder to manage all of 
the templates on your system. 
Global templates are available to all 
animation projects on your system.

This is the Library Preview 
panel.
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Step 3: Adding and Attaching a Peg to the Old 
Man 
This is the first step to creating a motion path for the old man. 

To add a peg and attach the old man to it:

1. In the Timeline window, select the old man walk cycle element.

2. Click the Add Parent Peg  button at the top of the Timeline window to add a Peg 
element to your animation and attach the old man walk cycle element as its child 
element. 

3. With the Peg selected, select Element > Rename Peg Element to open the Rename 
Element dialog box and change the name of the peg to Peg-oldman. 

4. Click OK to confirm the name change.
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Step 4: Creating a Motion Path for the Old Man
This is the biggest step in this lesson. In this step you will get to do something a bit more 
challenging - you’re going to make a motion path with the peg you just added. This 
motion path will move the old man from the west to east side of the stage.

You will use three Sceneplanning view windows to design and play back your motion 
effect.

To create a motion path:

1. Advance the red frame slider at the top of the Timeline window to frame 1, where 
the old man peg will start.

 
2. In the Timeline window, select the Peg element you just added and the Show/Hide 

 button at the top of the window so that no elements are showing. 

3. Click the checkboxes next to the Peg-oldman and Camera elements so that only they 
are displayed. 
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At this point, your peg is just a red circle at the center of the Top View and Side 
View windows.

Your Top and Side View windows will look something like these.You may have to 
zoom and pan your windows 
to get the same views of these 
windows.

• To pan a window, press 
[Spacebar] and use the 
Grabber tool to move 
your view of the window.

• To zoom in, press [X].

• To zoom out, press [Z].

• To reset the view, press 
[Shift]+[V].

Use the Show/Hide 
checkboxes to display 
the elements
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4. With the Select  tool, drag the center of the peg’s red circle to move the peg in the 
Top View or Side View windows.
• In the Side View window, the peg should stay in the middle as shown, you 

should not need to move anything.

 
• In the Top View window, place the peg a little bit past the east side of the 

camera angle.
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5. Make sure you have the Peg element selected in the Timeline window and select 

Tools > Sceneplanning Tools > Motion to activate the Motion  tool.

6. With the Motion  tool in the Top View window, drag the last keyframe on the 
motion (which is on the right) path towards the est side of the camera frame.

 

When you activate the Motion 
tool, two keyframes appear on the 
peg.

• The first keyframe is on the 
left.

• The last keyframe is on the 
right.
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Step 5: Creating a Motion Path for the Ghost
Now is the time to add a little bit of atmosphere to our scene, we will introduce a ghost 
into the room, this explains the reason that the old man is moving so carefully.

1. Create a new peg for the ghost.

2. Advance the red frame slider at the top of the Timeline window to frame 110, where 
the ghost peg will start.

3. Select the first frame of the ghost’s peg and use the Motion  tool to place the 
ghost outside of the camera frame in the camera view.
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4. Advance the red frame slider at the top of the Timeline window to frame 145, where 
the ghost peg will end.

5. Use the motion tool to drag the ghost outside of the scene so that it crosses the 
screen.
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6. Hold [Shift] and click the middle of the motion path for a motion point to be added 
to the path as a green dot. You can now drag the green motion point to create a 
Vee-shaped path.
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7. Click on the green motion point to change the information in the properties window. 
You can now change the tension to -1 for the Vee-shaped motion path to be changed 
to a round-shaped motion path.

8. Select the first keyframe of the ghost’s peg in the Timeline window for the 
properties information to change. You will now have the option “Orient to Path“.
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9. Activate this option. The ghost will now follow the path, creating a much smoother 
animation.

 

10. Click the Show/Hide  button to show all elements in your animation and then 
select Play > Quick Preview. This command renders your final animation so that you 
can play it back in real-time.

11. Use the Playback window to watch the old man walk across the room as the ghost 
passes quickly by.
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Step 5: Export
Well, you have successfully created a multiplane camera move and motion path. Now it’s 
time to package your creation so that you can share it with friends and family!

To export your animation:

1. Select File > Export Movie. The Export dialog box opens.

2. From the Export Format menu, select Flash Movie.

3. Select Default from the Settings menu. 

4. Type the name of the movie in the File Name field and click the Browse button if you 
want to select an alternate location for the final file. 

5. Select Full Movie from the Export Type panel.

6. Select the Launch Player After Export option.

7. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export. If you want to cancel the export, click Cancel. 

If you had any trouble with this lesson, check out the Sceneplanning_Final animation 
project to see how we did it.
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Lesson 5: Creating Cross-Dissolves with 
Colour Transform Elements

Toon Boom Studio includes a Colour Transform element, which you can use to change the 
colour properties of an element over time. 

In the lesson scene, a skater does some fancy tricks on a half-pipe. To accentuate his 
daring boardwork, you will use a Colour Transform element to create a series of cross-
dissolves that change the transparency of the skater at different frames.

There are two animation projects for this lesson:

• ColourFX_rough
• ColourFX_Final

You will use the ColourFX_Rough animation project to follow the steps in the lesson. When 
you have questions that you are not sure about, you can refer to ColourFX_Final to see 
how we did it. 

You will work mostly in the Timeline window 
to add and modify Colour Transform 
elements to create cross-dissolves.
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To start the Creating Colour Effects lesson:

1. Download the Quick Start Tutorial files from the Toon Boom Animation website. You 
can click the Quick Start Tutorial link on the Welcome Screen to open the 
appropriate Web page.

2. Open the ColourFX_Rough animation project in the Lesson5_ColourFX folder.

3. Save the animation in a location of your choice using File > Save As. Saving this 
animation project to a new location will ensure that you always have the original to 
return to and use should you want to.

4. Select Play > Play to play back the rough animation. 

Notice how two images of the skater appear to overlap for several frames? Well, in 
this lesson, you are going to make the overlapping images fade-in/out to create a 
series of cross-dissolves (chain mix).

Step 1: Adding the First Colour Transform Element
To change the colour of a drawing or image element over time, you attach it to a Colour 
Transform element and then use this element to specify how the colours in the elements 
attached to it will change.

During the cross-dissolve you will create, two drawings will appear at the same time, one 
fades in while the other fades out. To achieve this effect, we placed each drawing in a 
separate element layer so that you can control them independently. You’ll see as we 
progress through the lesson how this enables you to create cross-dissolves.

We have put the 
drawings for the 
skater in 
different 
elements so that 
we can create 
the cross-
dissolve effect.
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To add the first colour transform element:

1. Click the Add  button at the top of the Timeline window. The New Elements 
dialog box opens.

2. Enter information about the element in the New Elements dialog box:
From the Type menu, select Colour Transform Effect.
In the Name field, type skateColour and click OK. A new element layer 
appears in the Timeline window.

3. In the element list on the left-side of the Timeline window, attach the Colour 
Transform-skateColour element to the SkatePeg2 element by dragging and 
dropping it just below the peg.

 

4. Attach the sk_2 element to the Transform-skateColour element by dragging and 
dropping it on top of the effects element. 
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5. Change the start and duration of the Transform-skateColour element so that it 
matches the start and duration of the sk_2 element.

Double-click the trackbar of the Transform-skateColour element to select it and 
drag it to frame 12.

 
Drag the end of the trackbar so that it ends on the same frame as the sk_2 
element (frame 20).

 

6. Select File > Save to save your animation project.

Step 2: Adding Keyframes and Set their Values
In the first Colour Transform effect, the drawing should fade out from frame 16 to frame 
20. 

To achieve this, you must add a keyframe at frame 16. Then, at the keyframe on frame 20, 
you must make the attached elements completely transparent.

With colour transforms, you can chose to do an additive or a multiplicative colour 
transform. 

• In additive colour transformations, you select a colour value that is added to all 
of the colour values in an element.

• In multiplicative colour transformations, you select a value (usually between 0 
and 1) and multiply this value with all of the colour values in an element to arrive 
at a final value.
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Because the effect you want to create in this lesson is an even transformation of the alpha 
value (transparency) of element colours, you will create multiplicative colour 
transformations. 

To make an element change from transparent to opaque to transparent, you must multiply 
the alpha values by 0, 1, and 0. When you multiply an opaque colour (255 alpha) by 0, the 
result is 0 which makes the colour transparent.

To add a keyframe and set its value:

1. Advance the red frame at the top of the Timeline window to frame 16.

2. From the element list on the left-side of the Timeline window, select the Transform-
skateColour element. Notice in the Properties window (Window > Properties) that 
the Colour Transform tab opens.
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3. In the Colour Transform tab, click the Add  button to add a keyframe to the 
selected frame on the Transform-skateColour element. 

4. Advance the red frame slider at the top of the Timeline window to frame 20. 

5. On the Colour Transform tab, drag the Alpha slider in the Multiplicative section of 
the tab all the way to the left. The value should appear as 0 in the Alpha field.

6. Drag the red frame slider at the top of the window from frame 11 to 20 and watch as 
the element fades-out.

7. Select File > Save to save your animation project.

Step 3: Creating the Next Colour Transform Effect
In this step, you are going to create another colour transform effect, for the next element 
in the series, that will go from transparent to opaque to transparent.

To achieve this effect, you will add a Colour Transform element, set three keyframes, and 
multiply the alpha value at each keyframe by 0, 1, and 0.

To create the next colour transform effect:

1. Add a Colour Transform element and name it skateColour2.

2. Drag and drop the Colour Transform-skateColour2 element just before the sk_3 
element in the element list. This will also attach it to the SkatePeg 2 element.

3. Attach the sk_3 element to the Colour Transform-skateColour2 element.

4. Change the start frame of the Colour Transform-skateColour2 element so that it 
matches the sk_3 element. Start frame: 16; End frame: 24.

A square appears in the 
Timeline to identify the 
keyframe on the trackbar.
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5. Add a keyframe to the Colour Transform-skateColour2 element at frame 20. Your 
Timeline window should now look something like this:

6. In the Colour Transform tab, set the keyframes to the following multiplicative alpha 
values:

Frame 16: 0
Frame 20: 1
Frame 24: 0

7. Drag the red frame slider from frame 16 to 24 and watch how the first element fade 
out as the second one fades in and then out again. 

You’ll notice how the drawing in the next element appears for the last five frames. In 
the next step you’ll use the exact same colour transform element to fix all of the 
other elements so that they undergo the same colour transform effect.

8. Select File > Save to save your animation project.

Step 4: Cloning the Colour Transform Effect
All of the remaining elements, except for the last, must undergo the same colour 
transform effect as you created in Step 3. Rather than duplicating your efforts, you can just 
clone the Colour Transform element and attach the other elements to it. 

When you clone a Colour Transform element, all of the information stored in the effect are 
duplicated so that you do not have to re-create keyframes or their values. If you update 
any one clone with new values, Toon Boom Studio will update all the other clones with the 
new values.

To clone the colour transform effect follow these steps:

1. In the Timeline window, select the Colour Transform-skateColour2 element.

2. Select Element > Clone Element. Toon Boom Studio creates a new element and 
names it Colour Transform-skateColour2(1) and renames the original element 
Colour Transform-skateColour2(0). The new element appears at the top of the 
element list in the Timeline window.

3. Attach the new element to the SkatePeg2 element and attach the sk_4 element to 
the Colour Transform-skateColour2(1) element.
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4. Drag the trackbar of the colour transform element so its start/end frame matches the 
element you want it to transform.

5. Repeat the previous steps for the elements sk_4 to sk_7. Make sure that as you 
attach the skater elements to the Colour Transform elements that you maintain their 
layer order in the element list.

When you are done, your Timeline window should look like this.

6. Select Play > Play to play back the rough animation.

You just have to create the effect for the last element in the series and the effect will 
be complete!

7. Select File > Save to save your animation project.

Step 5: Creating the Last Colour Transform
Now, all that is left is the colour transform for the last element that makes up the skater.

For the last colour transform effect, the skater will start out transparent, become fully 
opaque and remain opaque for the rest of the scene.

To create this effect, you will add one keyframe to a Colour Transform element, give the 
first keyframe a multiplicative alpha value of 0 and give the second keyframe a 
multiplicative alpha value of 1.

This step is basically the reverse of step 2, in which you made the character start opaque 
and then end transparent.

To create the last colour transform:

1. Add a Colour Transform element and name it skateColour3.

2. Attach the Colour Transform-skateColour3 element to the SkatePeg2 element and 
attach the sk_8 element to the Colour Transform-skateColour3 element. 
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3. Change the duration of the Colour Transform-skateColour3 element to 9 frames 
and make the element start on frame 36.

4. Add a keyframe to frame 40 of the Colour Transform-skateColour3 element.Your 
Timeline window will look something like this:

5. In the Colour Transform tab, set the keyframes on the colour transform element to 
the following multiplicative alpha values:

Frame 36: 0
Frame 40: 1

6. Select File > Save to save your animation project.

Step 6: Export
That’s it! You’ve created a pretty nifty colour transform effect with one of Toon Boom 
Studio’s latest effects.

All that is left to do is to export your animation and watch it play!

To export your animation:

1. Select File > Export Movie. The Export dialog box opens.

2. From the Export Format menu, select Flash Movie.

3. Select Default from the Settings menu. 

4. Type the name of the movie in the File Name field and click Browse button if you 
want to select an alternate location for the final file. 

5. Select Full Movie from the Export Type panel.

6. Select the Launch Player After Export option.

7. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export. If you want to cancel the export, click Cancel. 

After the animation is rendered, a Playback window will open and play back your 
animation.

That’s it! If you had any trouble with this lesson, check out the Colour_FX_final animation 
project to see how we did it.
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Lesson 6: Creating Clipping Mask Effects
Toon Boom Studio includes a Clipping Effect element, which you can use to mask out parts 
of an image to reveal only those portions you want to. 

In the lesson scene, you will merge two extreme sports scenes (mountain bike guy and 
surfer guy) using a mask to reveal the second scene. While you work on this effect, we 
hope you learn some other things too!

There are two animation projects for this lesson:

• MaskFX_Rough

• MaskFX_Final

You will use the MaskFX_Rough animation project to follow the steps in the lesson. When 
you have questions that you are not sure about, you can refer to MaskFX_Final to see how 
we did it. 

To start the Creating Clipping Mask Effects lesson:

1. Download the Quick Start Tutorial files from the Toon Boom Animation website. You 
can click the Quick Start Tutorial link on the Welcome Screen to open the 
appropriate Web page.

2. Open the MaskFX_Rough animation project in the Lesson6_MaskFX folder.

3. Save the animation in a location of your choice using File > Save As. Saving this 
animation project to a new location will ensure that you always have the original to 
return to and use should you want to.

4. Select Play > Play to play back the rough animation. 

Notice how the two scenes - the one of the biker and the other of the surfer - just run 
into each other? In this lesson, we’ll create a transition between these two scenes out 
of a clip in the shape of a wave, which will reveal the surf scene. Take a look at the 
final animation project, MaskFX_Final, if you want to see what you will do.

See the wave hot on the trail of 
the biker? 

That is created by a mask 
element in the shape of the 
wave, which reveals an image 
of a wave below it.
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Step 1: Drawing the Mask
Like the masks worn by partiers at a Halloween ball, a Toon Boom Studio mask reveals 
certain visual elements while hiding others (like a Halloween mask reveals the eyes of the 
wearer, while covering most of the face).

For the first step in the creation of the mask effect, you must draw the mask that will reveal 
image(s) below it. You can only create masks from vector drawings.

We have already drawn a mask for you. The mask consists of a cycle of vector drawings of 
a wave, which will cut out an image of rolling waves beneath it. Take a look at the mask we 
drew so that you know what you can do when you create your next clip effect solo. 

To review the mask we created:

1. In the wave_mask element column in the Exposure Sheet window, press [Shift] and 
select frames 15 through 36.

2. Select Play > Play to play back the selection. 

Notice the wave cycle is a collection of painted vector drawings. The painted areas of 
these drawings will be like the holes in the Halloween mask that will let the images 
below it show through, assuming the shape of the mask drawings.

Step 2: Building the Clipping Element
After you have created the vector drawings that will act as your mask, or in this case, have 
seen the vector drawings that will act as the mask, you are ready to add the Clipping Effect 
element.

Clipping Effect elements consist of two parts: the clip element and the mask parameter. 

• To the clip layer, you attach the elements that you want to show through the 
mask.

• To the mask parameter, you attach the vector drawing element that you want to 
use as a mask.

With the onion skin on, you can 
see the cycle of drawings that fit 
together to make the mask.
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You will notice in our setup, that we have attached the wave_mask vector element to a 
peg, that moves the wave in the scene.

To build the mask element:

1. Click the Show/Hide checkbox next to the wave_mask element so that you can see 
it.

2. Click the Add  button at the top of the Timeline window. The New Elements dialog 
box opens.

3. From the Type drop-list, select Clipping Effect, type waveEffect in the name field 
and click OK.

The Timeline window will look like this:

• Here’s the clip layer.

• Here’s the mask parameter.

• Here’s the vector element that is attached to 
the peg.

• Here’s the clip that will “show through” the 
mask.

• Here’s the 
Clipping layer.

• Here’s the 
Mask 
parameter.
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4. Drag and drop the Peg element on top of the Mask layer. When you drag the Peg 
element, the vector element attached to it will move with it as well. You have now 
created the mask!

 

5. Drag the wave.swf Media element on top of the Clipping-waveEffect layer. The clip 
layers appear below the mask layers, but are indented out from the mask layers.

 

Step 3: Export
Well now that you have created your clip mask effect, you are ready to export and show 
the world the fruits of your labor!

To export your animation to SWF:

1. Select File > Export Movie. The Export dialog box opens.

2. From the Export Format menu, select Flash Movie.

3. Select Default from the Settings menu. 

4. Type the name of the movie in the File Name field and click the Browse button if you 
want to select an alternate location for the final file. 

5. Select Full Movie from the Export Type panel.

6. Select the Launch Player After Export option.

7. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export. If you want to cancel the export, click Cancel. 

After the animation is rendered, a Playback window will open and play back your 
animation.

There is an element with some text in it, which we imported from an Adobe® Illustrator® 
file. To experiment more with the Mask effect, you can replace the existing mask with this 
element. Remember you will have to change the start time and exposure of this drawing 
so that it matches the duration of the transition.
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Lesson 7: Retouching Drawings in 
Sceneplanning

In previous versions of Toon Boom Studio, when you animated drawings with pegs in 
Sceneplanning views, you would have to switch to a different state, called Drawing Mode, 
to retouch drawings. However, this was difficult to do in Drawing Mode because you were 
not able see how drawings would be positioned relative to each other as a result of 
Sceneplanning view animations. 

Toon Boom Studio makes it possible to retouch drawings more accurately and easily 
because you can see how drawings in different elements work together when animated.

There are two animation projects for this lesson:

• DrawingSceneplanning_Rough

• DrawingSceneplanning_Final

You will use the DrawingSceneplanning_Rough animation project to follow the steps in the 
lesson. When you have questions that you are not sure about, you can refer to 
DrawingSceneplanning_Final to see how we did put the final scene together. 

To start the “Drawing in Sceneplanning” lesson:

1. Download the Quick Start Tutorial files from the Toon Boom Animation website. You 
can click the Quick Start Tutorial link on the Welcome Screen to open the 
appropriate Web page.

2. Open the Lesson7_DrawingSceneplanning animation project in the 
Lesson7_DrawingSceneplanning folder.

3. Save the animation in a location of your choice using File > Save As. Saving this 
animation project to a new location will ensure that you always have the original to 
return to and use should you want to.

Over the duration of the sample scene, Tania 
bends her arm. The joints at her shoulder and 
elbow rotate to create the bending motion.

In this tutorial, you will use “Drawing in 
Sceneplanning” to fix gaps that appear at the 
elbow and shoulder as a result of the bending 
action.
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You are now ready to begin working on the sample scene.

Step 1: Playing Back the Scene
In this first step, you will play back the rough scene to identify problems that arise from 
the rotation of the joints in the shoulder and elbow.

To play back the scene:

1. Click the Loop  button in the toolbar, then click Play .

2. Look closely at the shoulder and elbow as the animation plays back. Press [X] to 
zoom in close to the image. Press [Spacebar] and drag the window to focus on 
Tania’s left side.

Click the white space 
to remove the 
selection frame.

Notice the gap that appears at the 
shoulder joint.

Notice also the gap that appears in the 
line art at the elbow.

You will fix both of these problems in the 
following steps.
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3. Click Stop  to stop the playback.

Step 2: Retouching the Elbow Joint
In this step, you will use the Brush tool to retouch the line art on the elbow joint.

You must select a drawing element, the frame that contains the drawing you want to 
retouch, and a drawing tool. You can draw directly in the Camera View window.

All elements that are shown in the Timeline window will appear in the Camera View 
window.

To retouch the elbow joint:

1. In the Timeline window, select the “forearm left” element.

2. Drag the red frame slider to the frame 15 in the scene. At frame 15, the gap between 
the upper arm and forearm is the greatest. Correcting the drawing at this frame 
should fix the error for the duration of the animation.

3. From the Drawing Tools toolbar, select the Brush  tool. To open the Drawing 
Tools toolbar, select Window > Drawing Tools.
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As soon as you activate one of the drawing tools, you enter in “Edit Drawing” mode.

4. Set up your drawing space so that you can work on the elbow.
If the grid is on, you will see it in the Camera View. Press [G] to turn it off.
To zoom in, press [X].
To pan the window, press [Spacebar] and drag the window.
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5. In the Properties window, click the Pen tab, set your Minimum Size to 4 and the 
Maximum Size to 6.

6. From the Colour Palette tab, select the “line” swatch from the “tania” palette.
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7. Use the Brush tool to connect the stroke on the forearm to the stroke on the upper 
arm.

8. Click Play  and watch the elbow as it bends. If there are any problems in your 
retouching, undo what you did and try again. Click Stop  to stop the playback 
before you try to redo your work.

Step 3: Creating the Shoulder Joint
That was a simple retouch example. The next fix is a little bit more sophisticated.

In the shoulder, the gap between the shoulder and the upper arm is large. In this step, you 
will practice a technique that will help you animate future jointed characters.

To fix the hole between the torso and the upper arm, you will create a perfect circle that 
will act as the joint on which your upper arm will rotate. The circle will overlap the upper 
arm and torso so that no gaps will appear while the joint rotates. You can try this technique 
with other jointed characters you create.

To create the shoulder joint:

1. In the Timeline window, select the upper arm element and move the red frame 
slider to frame 1.

2. Zoom and pan the Camera View window so that you have a close-up view of Tania’s 
left shoulder.

3. From the Drawing Tools toolbar, select the Ellipse  tool. 

4. In the Properties window, click the Pen tab and change the Maximum Size value to 
6.

5. Click the Colour Palette tab, select a red colour swatch from the Default palette. 
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You will draw the circle with red, and not the colour of Tania’s shirt, so that you can 
easily see the edges of the circle, which will help you position it. After you position 
the circle, you will paint it with the colour of Tania’s shirt and delete the red line art of 
the circle.

6. In the Camera View window, press [Shift] to draw a perfect circle and then use the 

Select  tool to position the circle in the gap that is the shoulder.

7. Press [Esc] to release the selected circle.
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8. From the Properties window, click the Colour Palette tab, select the “shirt” swatch 
from the “tania” palette.

9. From the Drawing Tools toolbar, select the Paint  tool and click inside the red 
circle to fill it with the “shirt” colour.
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10. With the Select  tool, select the red line art around the circle and delete it.

11. Click Play  and watch the shoulder as it bends. If there are any problems in your 
joint, undo what you did and try again. Click Stop  to stop the playback before you 
try to redo your work.

Step 4: Retouching the Shoulder
After you have created the joint that will fill the gap between the torso and the upper arm, 
you have to add the line art that will cover the joint.

To retouch the shoulder:

1. In the Timeline window, select the “upper arm” element.

2. Drag the red frame slider to the first frame in the scene. At frame 1, the gap between 
the torso and the upper arm is its greatest. Correcting the drawing at this frame 
should fix the error for the duration of the animation.

3. From the Drawing Tools toolbar, select the Brush  tool. 

4. From the Properties window, click the Colour Palette tab, select the “line” swatch 
from the “tania” palette.
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5. Use the Brush tool to draw the line art over the shoulder.

6. Click Play  and watch the shoulder. If there are any problems in your line art, undo 
what you did and try again. Click Stop  to stop the playback before you try to redo 
your work.

Step 5: Export
Export your scene and show others what you can do with the new “Drawing in 
Sceneplanning” feature.

To export your animation to SWF:

1. Select File > Export Movie. The Export dialog box opens.

2. From the Export Format menu, select Flash Movie.

3. Select Default from the Settings menu. 
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4. Type the name of the movie in the File Name field and click Browse if you want to 
select an alternate location for the final file. 

5. Select Full Movie from the Export Type panel.

6. Select the Launch Player After Export option.

7. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export. If you want to cancel the export, click Cancel. 

After the animation is rendered, a Playback window will open and play back your 
work. 
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